MOD failure

I was relaxing, in the middle of watching a movie when suddenly, the screen froze and turned blue (the blue screen of death)! I tried turning the cable box off and on and realized that the power button (on the newly installed box) wasn’t operational. Hmmmm, what now? I unplugged everything from the back of the box, plugged it all back in – and still nothing. The green power light is on but I definitely don’t have a signal. I’m thinking the box is defective. What to do….I don’t pay a lot for the few channels I get on the telly but when I am in the middle of watching something, it’s annoying to be interrupted. Equally annoying is attempting to call Chunghwa telecom on a holiday weekend for a solution. I call the number on the top of the box. The first issue is finding someone who speaks English. Then, after explaining the issue, I wait on hold while an animated discussion in Chinese ensues between several customer service reps. They want to know my username (what?), password (yeah, no)  phone number, address, ARC number. All I want to know is, is the cable out in my area. I explain that I think it’s the box and can someone please bring me a new one. Sure, they say, NEXT TUESDAY! Great! I get to take time off of work to wait around for the cable repair guy. Arrrrgh! In the meantime, I’m going to unplug everything and see if perhaps the box just got overheated….

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog Stats

  • 9,441 hits

As for me, I will take the road less travelled…

%d bloggers like this: